
Crear un Proyecto en Rational  RequisitePro. 

 
1. Seleccione el botón “Inicio”, luego “Programas”, “Rational RequisitePro”, entonces 
seleccione “Rational RequisitePro”   

2. Desde RequisitePro, haga click  en  Archivo > Nuevo> Proyecto. 

 
3. Pulse la etiqueta “New” en la ventana.  

4. Seleccione la Plantilla a utilizar y presion Ok 

5. Al aparecer la ventana de las propiedades del proyecto, escriba la información sobre el nuevo 
proyecto. 

 Nombre del proyecto (hasta 64 caracteres) 

 Manejador de base de datos 

 Descripción del proyecto (opcional, hasta 256 caracteres) 

6.  Haga clic en Ok. 

7. Cuando se le pregunte si desea crear un nuevo directorio para el proyecto, pulse el botón “Ok”.  
Recibirá el mensaje, “El proyecto de RequisitePro fue creado con éxito”.  

8. Pulse el botón  “Cerrar”. 

Abrir un proyecto existente 
 
1. Seleccione la opción  "File" del menú y seleccione "Open Project". 

2. Seleccione el proyecto que desea abrir dando doble clic sobre él o pulsando el botón “Ok” de la 
caja del diálogo "Open Project". 

3. RequisitePro abrirá el proyecto solicitado y la ventana se titulará "Rational RequisitePro - 
(Nombre del proyecto)".  

 

Crear un documento de casos de uso 

1. En el explorador, seleccióne el paquete Use Cases y haga click  en File > New > Document. 
Entonces aparece el cuadro de dialogo de las propiedades del documento. 



2. En el campo Name,tipee el nombre del requerimiento; en el campo Description, tipee la 
descripción del requerimiento ; y seleccione el Document Type  como Use Case Specification 
Document Type y haga click en  OK.  

3. En el nuevo documento, borre el texto azul que aparece debajo de 2.1 Basic Flow y presione la 
tecla Enter. 

4. Seleccióne el siguiente texto:  
 
Upon successful completion of the Checkout use case. 

5. En el explorador haga click en Edit > Copy. En el documento, haga click en la 
linea abajo de 2.1 Basic Flow, y haga click en Edit > Paste Special. Seleccione la 
opcion Unformatted text y haga click en  OK. 

Crear un nuevo requerimiento desde un documento.   
 
1. En la ventana del explorador del proyecto (lado izquierdo de la pantalla), seleccionar y hacer 
doble clic el  icono “VISION”. El documento se abrirá.  

2. Seleccionar el requerimiento que agregará al proyecto de la sección 5.1 del documento, donde 
están redactados los requerimientos. 

3. En la barra del menú, haga clic en RequisitePro > Requeriment > New. Aparecerá el cuadro de 

diálogo de Propiedades del requerimiento.  

4. De la lista tipo de requerimiento “Requeriment Type” seleccione el tipo de requerimiento que 
aplica al requerimiento que se está creando. 

5. En el campo “Name” escriba el nombre del requerimiento, y en el campo “Text”, una breve 
descripción de dicho requerimiento. 

6. Haga Clic a  “Ok”. 

7. Haga Clic a RequisitePro > Documment > Save 

8. Haga Clic a RequisitePro > Documment > Close 

Cree un nuevo requerimiento sin un documento 
 
1. Seleccione la carpeta en la cual se desea localizar el nuevo requerimiento  y presione File > New 
> Requirement. 

2. Aparecerá el cuadro de diálogo de las propiedades “Requeriment Properties”. 

3. En la pestaña General, seleccione de la lista el tipo de requisito, escriba el nombre en el campo 
Name, y la descripción en el campo Text. 

4. RequisitePro crea el nuevo requisito en la carpeta seleccionada y asigna luego la etiqueta 
disponible al requerimiento. 

 

Crear nuevos requerimientos en una vista 

1. En el cuadro de dialogo Open Project, seleccione My Exercise Project y haga click en OK. 

2. En el explorador, expanda el paquete Features and Vision y haga doble-click en All Features. 
La matriz de  All Features Attribute aparece. Explore los menus asociado con este tipo de vista. 



3. La ultima entrada en la columna de Requirements, tiene por titulo <Click here to create a 
requirement>. Haga click una vez para activar la fila, y haga click otra vez para comenzar a editarla. 

4. Tipee el nombre del nuevo requerimiento en el campo Name y la descripción del requerimiento 
en el campo Text. 

5. Haga click sobre cualquier otra celda de la vista, y el requerimiento es salvado en el documento 
y en la base de datos.  

Cambiar el valor de un atributo en una vista 

1. En el paquete Features and Vision , seleccione la vista All Features. Haga doble-click en la 
interseccion del requerimiento FEAT4 y la columna del atributo Status. Un drop-down menu 
aparece. 

2. Haga click en Approved, y setee el valor haciendo click en otro requerimiento o en otra celda. 
 

3. Haga click en  File > Save View, y cierre la vista haciendo click en la X en la esquina superior 
derecha. 

 
Vista del Historial de los requerimientos.   
 
1. Despliegue la opción “Edit” del menú y seleccione “Find”. 

2.  Introduzca el nombre del requisito y pulse el botón “Find Next”. El requerimiento se asentará 
en el Explorador. 

3. Haga clic en “Close” en el cuadro de diálogo  “Find”.  

4. Haga clic con el botón derecho del mouse sobre el requerimiento localizado y seleccione 
"Propiedades". 

5. Haga clic  en la pestaña "Revision". 

6. Pulse el botón "History".   

7. Finalmente aparecerá el cuadro de diálogo “Revisión History”.  

8. Pulse el botón “Close” en el cuadro de diálogo “Revisión History” y “Cancel” en el cuadro de 
diálogo “Requirement Properties”.   

 

Cambios de los atributos de los requerimientos 
 
 Para realizar los cambios en los atributos deben llevarse a cabo los siguientes 
pasos: 
1. En la ventana del explorador, seleccione el icono que identifica la matriz “All 
Features”. 

2. En el lado derecho de la ventana del explorador, se ven todos los requerimientos 
y sus respectivos atributos.  

3. Con el botón izquierdo del mouse haga clic en la columna prioridad “Priority” 
sobre el requerimiento visible que se desee actualizar. 

4. Haga clic de nuevo con el botón de la izquierda y seleccione un nuevo valor para 
la prioridad.  



5. Emplee el mismo procedimiento para cada uno de los atributos que se desee 
cambiar.  

 
 
 
 
 
 
Opciones Avanzadas: 
 
 
Respaldo de proyectos: 
 
  La opción Archive de RequisitePro le permite guardar una copia de su 
proyecto en un directorio seleccionado por usted. Para utilizar esta funcionalidad siga 
los siguientes pasos: 

 1. Seleccione la opción File > Project Administration > Archive > RequisitePro Archive. 
Aparece la ventana de Archive Project. 

 

Figura X. Diálogo de Archive Project.  

 

 2. Seleccione el directorio donde desea crear la copia de respaldo. Presione OK. 

 3.    Si desea cambiar la versión del proyecto, escribalo en el cuadro de texto: Revision #, 
este debe ser mayor o igual a el numero de versión actual. 

 4. Para aplicar el nuevo numero de versión a todos los documentos de requerimientos, 
seleccione la opcion: Propagate to all documents (offline documents excluded). 



 5.  Si desea asignar un numero de versión puede hacerlo en el cuadro de texto: Version 
Label. Tambien existe un cuadro de textos para reflejar cualquier cambio en el proyecto: Change 
Description 

 

El comando Archive realiza las siguientes operaciones:  

1 Crea el directorio para guardar los archivos.  Selecciona un nombre de la forma “BAKnnn” 
donde nnn representa el numero de version del proyecto. 

2 Copia los archivos del proyecto (.rqs y .rql) dentro del directorio 

3  Copia todos los documentos del proyecto dentro del directorio 

4 Actualiza la version del proyecto original 

5 Para proyectos que trabajan con Microsoft Access, el comando Archive realiza ademas las siguientes 
operaciones: 

Copia la base de datos del proyecto (.mdb) dentro del directorio 

Actualiza el archivo .mdb en el directorio de respaldo con la localizacion de los documentos del proyecto 
en el archivo. 

Añadiendo proyectos externos: 

 “Cross-project traceability” le permite establecer una relación de trazabilidad directa entre los 
requerimientos en diferentes proyectos de RequistePro. Esta caracteristica elimina el duplicado de datos, 
permitiendo la reutilización requerimientos entre varios equipos trabajando en proyectos relacionados.  

 Para conectar un proyecto externo con el proyecto actual, primero debe marcar los 
requerimientos en el proyecto externo para que soporten “external traceability”. Luego se debe adjuntar el 
proyecto, para ello debe seguir los siguientes pasos: 

Para permitir “cross-project traceability” para los requerimientos en un proyecto, debe hacer lo siguiente: 

1 Abrir el proyecto que será el proyecto externo 

2 Seleccione el proyecto en el explorador, y haga clic en: File > Properties 



 

3 En el “General tab” escriba un prefijo en el area Prefix. Este prefijo servirá para distinguir estos 
requerimientos de los del proyecto actual. 

4 Haga click en la pestaña “Requirement Types” , y seleccione el tipo de requerimiento que desea 
marcar para “external traceability”. 

 

5 Haga  Click en Edit. Aparecera el dialogo: Requirement Type. 

7 Seleccione la opción Allow External Traceability y haga Click en OK.  

8 Haga Click en OK para cerrar el dialogo  Project Properties 

 

Para adjuntar un proyecto externo al proyecto actual siga los siguientes pasos 



 1- Haga click en File > Project Administration > External Projects. Aparece  el menu para 
proyectos externos.  

 2- Haga Click en Add. Aparece el cuadro para adjuntar proyectos externos. 

 3- Localize el proyecto que desea, luego haga Click en Open. 

 4- Para especificar si el proyecto debe ser automáticamente conectado cuando el proyecto actual es 
abierto, seleccione la opcion de: Connect to the external Project en el dialogo project open. 

 

Mostrando las relaciones de trazabilidad: 

 Las relaciones de trazabilidad se pueden observar en la Traceability Matrix 

Grupos de discussion 

 Los grupos de discusión permiten intercambiar ideas, opiniones y preguntas entre un grupo de 
usuarios del proyecto (participantes).  

Creando discusiones: 

 1 Haga click en Tools > Discussions 

1.1   En la vista del explorador, selecciona uno o mas requerimientos y haga click en Requirement > 
Discussions. 

1.2  En Microsoft Word, seleccione un requerimiento y haga click sobre RequisitePro > Requirement > 
Discussions. 

  El cuadro de discusion aparecerá. 

 2 Haga click en Create. 

 3 Haga  click sobre las etiquetas correspondientes para definir la discusión, los 
participantes, asociar  requerimientos con las discusiones, etc. 

4 Click OK.  

 A través del icono  se puede saber si hay o no una discusión asociada con un proyecto o sus 
requerimientos.  

Integración con otras herramientas:  

 Como parte de Rational Suite RequisitePro forma parte de Rational Team Unifying Plataform, lo 
que permite a RequisitePro interacturar con las siguientes herramientas, las cuales forman para del 
Rational Team Unifying Plataform: 

• Rational Rose para análisis orientado a objetos, modelaje, diseño, y construccion 

• ClearQuest for team-based change request management 

• TestManager para la gerencia de pruebas de software 



• ClearCase LT para la configuración de gerencia 

• SoDA para la elaboración de reportes y documentos sobre los proyectos 

• Rational Unified Process para la incorporación de buenas practicas de desarrollo 

También puede ser usado con herramientas de otros fabricantes, como Microsoft Project, de Microsoft. 

Gerencia integrada de casos de uso: 

 La gerencia integrada de casos de uso entre Rational Rose y Rational RequisitePro le parmite 
manejar casos de uso usando atributos (tales como prioridad, riesgo, status, iteracion, etc.) asociando los 
casos de uso de Rational Rose con los documentos y Requerimientos de RequisitePro. 

 Para integrar un requerimiento con un caso de uso, seleccione: Tools > Rational Rose 

 

Integracion con RUP 

Rational Unified Process (RUP) es una base de conocimiento de principios de desarrollo de software. 
Como un proceso de ingenieria de software, RUP provee un enfoque disciplinado para asignar tareas y 
responsabilidades dentro de un equipo de desarrollo. Su meta es asegurar la produccion de software de 
alta calidad  que satisfaga los requerimientos de los usuarios, dentro de un horario establecido y 
ajustandose al presupuesto. Muchas de las actividades de RUP son soportadas por herramientas de 
ingenieria de software. Los Tool Mentors describen como las herramientas de desarrollo de software de 
Rational pueden ser usadas para soportar particulares fases y actividades dentro del proceso de desarrollo.  

Para acceder al Rational Unified Process Tool Mentors desde el RequisitePro haga click en Help > 
Extended Help 

Metricas de Requerimientos: 

Es una funcionalidad de RequisitePro for recoger estadisticas sobre los nombres, descripciones, atributos, 
relaciones y revisiones de los requerimientos. Los reportes son presentados in Microsoft Excel y pueden 
ser manipulados usando las funcionalidades de Excel. Existen dos clases de reporte, los reportes estaticos 
(los cuales muestran resultados del proyecto hasta el momento) y los analisis de tendencias (los cuales 
usan filtros basados en el tiempo que analizan los cambios en los atributos, trazabilidad, descripciones de 
los requerimientos) 

Se comienza creando uno o mas filtros. Los filtros establecen criterios para obtener informacion de los 
requerimientos. Por ejemplo, podria usar un contador para determinar cuantos requerimientos en el 
proyecto tienen una proriodad con el valor “High”. Puede combinar varios filtros para producir una 
consulta compleja. Los filtros que componen una consulta son agrupados usando el operador AND. 
Finalmente se pueden combinar varias consultas para producir un reporte. 

Para acceder las metricas haga click Tools > Metrics o el icono .  
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